Not a member yet? Why not Sign up today
Create an account  

  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
August 10 sprint update

#29
So, somewhere after 2.17, something changed that broke my mod (voidware).  The only change I did after 2.17 so far, was to set the gameversion: "2.2.2" to get it to load.  The fatal error on loading the mod goes - at least by error message - to area that I don't really know anything about:

Code:
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading types from Voidware, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null...
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Exception while loading plugin 'Voidware.dll':
System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <c95265f74fdf4905bfb0d5a4b652216c>:0 
  at BrilliantSkies.Core.Modding.ClassHolder.PreloadTypes (System.Reflection.Assembly asm) [0x00018] in <2f85a07e1c3e4c3fa1a1f1ee8bb8cf6e>:0 
  at BrilliantSkies.Core.Modding.PluginLoader.LoadAssemblies (System.Collections.Generic.List`1[T] validPlugins) [0x0003e] in <2f85a07e1c3e4c3fa1a1f1ee8bb8cf6e>:0 
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading types from ExampleMod, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null...

..and afterwards, the log fills within seconds with thousands of lines like this.  This happens before ever loading into designer - simply loading the game to the main menu:


Code:
NullReferenceException: Object reference not set to an instance of an object
  at SLua.LuaTimer.tick (System.Single deltaTime) [0x00049] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvr.tick () [0x00066] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvrGameObject.Update () [0x0000d] in <98246efba5524e30aaddee3569dc0a71>:0 
 
(Filename: <98246efba5524e30aaddee3569dc0a71> Line: 0)

NullReferenceException: Object reference not set to an instance of an object
  at SLua.LuaTimer.tick (System.Single deltaTime) [0x00049] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvr.tick () [0x00066] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvrGameObject.Update () [0x0000d] in <98246efba5524e30aaddee3569dc0a71>:0 
 
(Filename: <98246efba5524e30aaddee3569dc0a71> Line: 0)

Any idea on what causes this, or any pointers to where I should look into getting the mod working?

-- edit --
I'll attach logfiles with and without the mod (on the other one it's disabled from loading), in case it helps.


Attached Files
.zip   output_log_with_voidware.zip (Size: 5.93 KB / Downloads: 11)
.zip   output_log_without_mod.zip (Size: 3.16 KB / Downloads: 10)
Workshop: Voidware, INARI and more.
Reply



Messages In This Thread
August 10 sprint update - by Nick Smart - 2018-08-17, 04:16 PM
RE: August 10 sprint update - by SCUBAelement - 2018-08-17, 04:34 PM
RE: August 10 sprint update - by Aeralius - 2018-08-17, 04:46 PM
RE: August 10 sprint update - by benzo711 - 2018-08-17, 05:19 PM
RE: August 10 sprint update - by temeter - 2018-08-17, 05:23 PM
RE: August 10 sprint update - by Skyer - 2018-08-17, 07:42 PM
RE: August 10 sprint update - by Nick Smart - 2018-08-18, 10:50 AM
RE: August 10 sprint update - by BioPhoenix - 2018-08-17, 07:48 PM
RE: August 10 sprint update - by HerpeDerp - 2018-08-17, 08:57 PM
RE: August 10 sprint update - by Nick Smart - 2018-08-18, 11:01 AM
RE: August 10 sprint update - by HerpeDerp - 2018-08-19, 05:24 AM
RE: August 10 sprint update - by Nick Smart - 2018-08-18, 11:01 AM
RE: August 10 sprint update - by ThunderPanzer - 2018-08-18, 12:53 AM
RE: August 10 sprint update - by Renthrak - 2018-08-18, 09:15 AM
RE: August 10 sprint update - by benzo711 - 2018-08-18, 09:34 AM
RE: August 10 sprint update - by Nick Smart - 2018-08-18, 10:53 AM
RE: August 10 sprint update - by khkpck - 2018-08-18, 09:16 AM
RE: August 10 sprint update - by Nick Smart - 2018-08-18, 10:54 AM
RE: August 10 sprint update - by khkpck - 2018-08-18, 11:30 AM
RE: August 10 sprint update - by Nick Smart - 2018-08-21, 02:41 PM
RE: August 10 sprint update - by temeter - 2018-08-18, 11:57 AM
RE: August 10 sprint update - by Nick Smart - 2018-08-21, 02:06 PM
RE: August 10 sprint update - by Kpatrol88 - 2018-08-18, 12:54 PM
RE: August 10 sprint update - by Nick Smart - 2018-08-18, 01:45 PM
RE: August 10 sprint update - by BadRAM - 2018-08-18, 08:38 PM
RE: August 10 sprint update - by temeter - 2018-08-18, 10:23 PM
RE: August 10 sprint update - by CubeMaster_1 - 2018-08-19, 11:43 AM
RE: August 10 sprint update - by Dountoun - 2018-08-18, 11:57 PM
RE: August 10 sprint update - by pethy997 - 2018-08-19, 11:20 AM
RE: August 10 sprint update - by Skyer - 2018-08-19, 11:34 AM
RE: August 10 sprint update - by Kiriko - 2018-08-19, 12:28 PM
RE: August 10 sprint update - by Gladyon - 2018-08-19, 04:26 PM
RE: August 10 sprint update - by Kiriko - 2018-08-19, 04:43 PM
RE: August 10 sprint update - by Gladyon - 2018-08-20, 02:51 PM
RE: August 10 sprint update - by HerpeDerp - 2018-08-19, 08:15 PM
RE: August 10 sprint update - by Nick Smart - 2018-08-21, 02:09 PM
RE: August 10 sprint update - by MizarLuke - 2018-08-21, 02:03 AM
RE: August 10 sprint update - by DraWay - 2018-08-21, 04:08 AM
RE: August 10 sprint update - by ThunderPanzer - 2018-08-21, 03:24 AM
RE: August 10 sprint update - by temeter - 2018-08-21, 02:58 PM
RE: August 10 sprint update - by elexier909 - 2018-10-03, 04:25 PM
RE: August 10 sprint update - by MRSubscribe - 2018-10-03, 04:55 PM

Forum Jump:


Users browsing this thread:
1 Guest(s)