Not a member yet? Why not Sign up today
Create an account  

  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
August 10 sprint update

#21
(2018-08-18, 12:54 PM)Kpatrol88 Wrote: Found a fairly minor bug, Nick. When the avatar is sitting in a chair, they'll jump out of it when you press spacebar when you're in free camera mode. Merely annoying most of the time, but potentially deadly in adventure mode and the like.

Thanks I'll take a note of this. Here is the ticket stub, I've given it to Gladyon.

https://shareables.prod.atl-paas.net/emb...e/tKajDzaF

The 100th ticket in 8 days.
Reviewed FtD on steam yet? It's the #1 thing you can do to help FtD (and future games by Brilliant Skies!), so please take the time!
Bug tracker - view, "upvote", comment on and add all bugs here.
Request tracker - request new features here
support - private portal to service desk
Reply

#22
How hard would it be to add 2m and 4m turret bases? I want to make an even width ship with centerline guns.
(2016-07-12, 11:20 PM)Stufferino Wrote: Absolutely worthless? Seems like a perfect replica to me!

Reply

#23
(2018-08-18, 08:38 PM)BadRAM Wrote: How hard would it be to add 2m and 4m turret bases? I want to make an even width ship with centerline guns.

I doubt there are going to be further, major additions before the patch releases. Now it's mostly polishing for the release.
Reply

#24
Nick, i'm not sure if its known already, but I just build a ship that should sink (and does sink in 2.16) but doesn't sink in 2.2.2.
The ship doesn't have any air pumps and has no alloy below the waterline but still manages to float kinda wobbly.

Here is the ship:

.blueprint   USS Butterfly.blueprint (Size: 132.68 KB / Downloads: 10)
Reply

#25
(2018-08-18, 11:01 AM)Nick Smart Wrote:
(2018-08-17, 08:57 PM)HerpeDerp Wrote: Another juicy bug. Not new to devtest, but an important one nonetheless. Already posted on discord but posting here again:
In some situations shells don't collide with certain vehicles at all, even if the shells are not that fast and the other vehicle does not move at all. 
The attached blueprint should be a reliable way to reproduce it. It is a fortress though and a tall one so it may take some tries to not spawn it too low or high or it will take damage. The blueprint contains the target (an Atlas on a subvehicle spawner) and will start firing at it immediately. The shells should (or rather, they shouldn't) be flying through the atlas without hitting it.

Small clip of what happens (tracer shells flying through the Atlas. The Atlas being upside down has nothing to do with this):
https://gfycat.com/gifs/detail/TightDeepKronosaurus

It only seems to happen at very specific distances and the shells either collide normally or not at all with the vehicle. I'm guessing the problem lies not in the code where it checks whether shells collide with specific blocks but rather in the part where it decides to check or not check a vehicle at all.

I'll take a dive into the source code later today and will update this if I find the problem

Made a ticket for this 
https://shareables.prod.atl-paas.net/emb...e/Ha4jyZwp
Seems to be linked to a number of issues we're investigating.
I can say with decent certainty now that it is definitely not caused by GridCasting.GridCast. I wrote my own method to replace yours and it had the exact same problem, which would be a really weird coincidence. Also, it does not seem to depend much on the size of the vehicle, just its position.
Reply

#26
Hi, I just left the devtest and went back to the normal version. And than the game says, that Im chaeting and resets my level to 0. I know the level isnt that important in this game, but after 700 hours this is not so fun.
Reply

#27
@pethy997
https://forum.fromthedepthsgame.com/show...#pid381339
[Image: aOOx0bK.png]
There is always a weak-spot if you search Hard enough.

If you fire enough AP at that shield, at some point you're going to come through.

There is no "best" I wouldn't even say there is anything universally good, Good is subjective, I find everything bad even if it's in theory good against this or that.

Reply

#28
(2018-08-18, 08:38 PM)BadRAM Wrote: How hard would it be to add 2m and 4m turret bases? I want to make an even width ship with centerline guns.

pistons extended to half a meter placed sideways...
Once in a while I decide to do something stupid and try to perfect it. That is how some of my strongest designs were created.
Reply

#29
So, somewhere after 2.17, something changed that broke my mod (voidware).  The only change I did after 2.17 so far, was to set the gameversion: "2.2.2" to get it to load.  The fatal error on loading the mod goes - at least by error message - to area that I don't really know anything about:

Code:
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading types from Voidware, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null...
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Exception while loading plugin 'Voidware.dll':
System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <c95265f74fdf4905bfb0d5a4b652216c>:0 
  at BrilliantSkies.Core.Modding.ClassHolder.PreloadTypes (System.Reflection.Assembly asm) [0x00018] in <2f85a07e1c3e4c3fa1a1f1ee8bb8cf6e>:0 
  at BrilliantSkies.Core.Modding.PluginLoader.LoadAssemblies (System.Collections.Generic.List`1[T] validPlugins) [0x0003e] in <2f85a07e1c3e4c3fa1a1f1ee8bb8cf6e>:0 
 
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading types from ExampleMod, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null...

..and afterwards, the log fills within seconds with thousands of lines like this.  This happens before ever loading into designer - simply loading the game to the main menu:


Code:
NullReferenceException: Object reference not set to an instance of an object
  at SLua.LuaTimer.tick (System.Single deltaTime) [0x00049] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvr.tick () [0x00066] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvrGameObject.Update () [0x0000d] in <98246efba5524e30aaddee3569dc0a71>:0 
 
(Filename: <98246efba5524e30aaddee3569dc0a71> Line: 0)

NullReferenceException: Object reference not set to an instance of an object
  at SLua.LuaTimer.tick (System.Single deltaTime) [0x00049] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvr.tick () [0x00066] in <98246efba5524e30aaddee3569dc0a71>:0 
  at SLua.LuaSvrGameObject.Update () [0x0000d] in <98246efba5524e30aaddee3569dc0a71>:0 
 
(Filename: <98246efba5524e30aaddee3569dc0a71> Line: 0)

Any idea on what causes this, or any pointers to where I should look into getting the mod working?

-- edit --
I'll attach logfiles with and without the mod (on the other one it's disabled from loading), in case it helps.


Attached Files
.zip   output_log_with_voidware.zip (Size: 5.93 KB / Downloads: 9)
.zip   output_log_without_mod.zip (Size: 3.16 KB / Downloads: 10)
Workshop: Voidware, INARI and more.
Reply

#30
(2018-08-19, 12:28 PM)Kiriko Wrote: So, somewhere after 2.17, something changed that broke my mod (voidware).  The only change I did after 2.17 so far, was to set the gameversion: "2.2.2" to get it to load.  The fatal error on loading the mod goes - at least by error message - to area that I don't really know anything about:

The current devtest version is totally incompatible with any previous plugin.
The reason is that the code has been heavily refactored, including the fact that the dll has been split into several dlls.
You have to fix the compile errors and recompile the plugin.
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)