Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
[2.17 Devtest] Lighting is extremely laggy

#1
With the new shader, my fps becomes really slow if there's more than 5 light sources on any vehicle.
Some ships with more rooms may even drop the fps to less than 1, so can't even remove the lights to use the vehicle.

By the way, the new textures are pretty good, but I think the APS is way too dark. o((⊙﹏⊙))o.
Reply

#2
I doubt that it comes from the lights, I tried to add a dozen lights on the initial raft and had no problem, can you also try to add light to this raft to see if you can reproduce the problem?

If adding lights on the initial raft do not slow down the game significantly, that means that you have another problem, in that case please zip and post the logfile (after having reproduced the slowdown and closed FtD). The logfile is here:
macOS ~/Library/Logs/Unity/Player.log
Windows C:\Users\username\AppData\LocalLow\CompanyName\ProductName\output_log.txt
Linux ~/.config/unity3d/CompanyName/ProductName/Player.log
Reply

#3
(2018-04-15, 02:57 PM)Gladyon Wrote: I doubt that it comes from the lights, I tried to add a dozen lights on the initial raft and had no problem, can you also try to add light to this raft to see if you can reproduce the problem?
Without lights
[Image: mk9oRaQ.jpg]
With lights
[Image: Lg40cb5.jpg]
Reply

#4
I add more lights on the raft (judging from you screenshot, you have added more than a dozen of lights), and didn't really saw some slowing down.
But, my video card went crazy and very hot in a few seconds.

I suspect that's your slowdowns are coming from your video card. I have a GTX 770.
What is your configuration?
Reply

#5
(2018-04-15, 03:51 PM)Gladyon Wrote: I suspect that's your slowdowns are coming from your video card. I have a GTX 770.
What is your configuration?

OS: Windows 10 1803 Version 17133.73 64-bit
CPU: Intel Core i7-4770 @ 3.4 GHz 4 cores
RAM: 16 GB
GPU: NVIDIA GeForce GT 640 (4096 MB)

In previous versions (before the new shader), the lighting was just fine. The game didn't lag even with about 100 lights until 2.17.
Reply

#6
(2018-04-15, 04:30 PM)Why7090 Wrote:
(2018-04-15, 03:51 PM)Gladyon Wrote: I suspect that's your slowdowns are coming from your video card. I have a GTX 770.
What is your configuration?

OS: Windows 10 1803 Version 17133.73 64-bit
CPU: Intel Core i7-4770 @ 3.4 GHz 4 cores
RAM: 16 GB
GPU: NVIDIA GeForce GT 640 (4096 MB)

In previous versions (before the new shader), the lighting was just fine. The game didn't lag even with about 100 lights until 2.17.

It must come from the new shaders, they are much more complex than the previous ones.
We'll see what we can do, but I'm not sure if there iss something to do.
Reply

#7
(2018-04-15, 04:57 PM)Gladyon Wrote: It must come from the new shaders, they are much more complex than the previous ones.
We'll see what we can do, but I'm not sure if there iss something to do.

I don't think this kind of lighting (without shadow nor ambient occlusion, just blending colours) is very complex, so we might be able to optimize the shader...
If that's impossible or hard to do, can we just add an option in settings to use a simpler shader?
Reply

#8
(2018-04-15, 05:44 PM)Why7090 Wrote: I don't think this kind of lighting (without shadow nor ambient occlusion, just blending colours) is very complex, so we might be able to optimize the shader...
If that's impossible or hard to do, can we just add an option in settings to use a simpler shader?

We're using Unity's standard shaders, with some custom modifications (some vertex color customization for example).
Reply

#9
Or let this new shader activate in the most detailed display mode, otherwise off?

Also I have a question:
I can set up display details before starting the game in the little box menu, and in-game too.
The in-game setting never corresponds to the before game setting, I always have to set it manually ingame.
Which one is really setting the graphic details?
From the Depths english playlist starts here, before that it's hungarian:
https://youtu.be/Ltdx0yVI9cA?list=PLImar...ZokVtdBa73
MULTIPLAYER!

[Image: 6yFiDvF.jpg]
Reply

#10
(2018-04-16, 09:18 AM)Normal69 Wrote: Or let this new shader activate in the most detailed display mode, otherwise off?

Also I have a question:
I can set up display details before starting the game in the little box menu, and in-game too.
The in-game setting never corresponds to the before game setting, I always have to set it manually ingame.
Which one is really setting the graphic details?

It may not be that easy, the textures need to be adapted to the shaders.
So, using a simpler shader may force us to have a second set of textures (and there's not one texture per material, but several textures, so that will make a lot of them).
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)