Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
Hover with PID?

#1
A very heavy hovercraft of mine here.

I wanted to use PID combined with upward jets so that it hovers naturally.

But the AI's error correction response always overdoes it.

Not sure on how to tune that down.

Please help.

P.S.There is also a bug where the test stimulus cannot be changed after a while, no idea why.


Attached Files
.blueprint   Guardian HV PID.blueprint (Size: 116.42 KB / Downloads: 17)
Reply

#2
with the bug you need to close the editor back to the main menu and re open it. Make sure editing the pid is the first thing you do once you load in the blueprint. It should save the settings. Something about leaving the editor open or doing things before editing the pid causes the bug. As for the hover settings i copied the settings from a scarlet dawn ship once have them written down.
Altitude above terrain
.450
3.
1.
pitch
.1
3.
1.
roll
.1
3.
1.(1 gave me a very jerky correction my ship had Parkinsons .5 worked in my case)
I ended up using naval ai with it set to use jets in and out of water. This allowed my airship to broadside. If you want to face your enemy use land ai set a minimum distance and your ship will back away when enemies get too close. Arial ai is good for strafing runs if you dont want it to override the pid set its altitude to the same as the pids and set roll to 0. If you want your ship to roll when it turns then weaken or remove the roll pid.
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)