From The Depths - Forum
How to keep planes from going into orbit? - Printable Version

+- From The Depths - Forum (https://forum.fromthedepthsgame.com)
+-- Forum: Alpha (https://forum.fromthedepthsgame.com/forumdisplay.php?fid=9)
+--- Forum: TUTORIALS (https://forum.fromthedepthsgame.com/forumdisplay.php?fid=127)
+--- Thread: How to keep planes from going into orbit? (/showthread.php?tid=33667)

Pages: 1 2


How to keep planes from going into orbit? - Levits - 2018-02-13

Not sure where to look to for this supposedly simple answer, but I have built a plane, it is stable with all control surfaces needed and the AI seems to know what it is doing while piloting it... except for the fact that the thing constantly increases its altitude.

I have a dedicated heli-blade setup at the front to continuously provide propulsion, but I am assuming that the AI should nose the aircraft down when it reaches the set maximum altitude; and nose up when it dips below.

For some reason though, the thing continues to angle upwards. All the way into the stratosphere at 3000meters.

I would like to turn it into a torpedo bomber and/or missile bomber flying just over 200meters and not below 150. While also firing the torpedo/missile at about 100meters or so from the target (aiming straight at it).

If anyone knows the specific settings for the AI cards (both targeting and simply piloting) or some physical alteration needed for the plane to keep it from constantly increasing altitude that I can use to ensure that this thing doesn't go launching itself into low orbit, I'd really appreciate it.


RE: How to keep planes from going into orbit? - Liondrome - 2018-02-13

try reducing the number of wing pieces, they produce a TON of lift. Consider placing more ailerons or even dedicated heliblades as these don't produce lift by themselves.


RE: How to keep planes from going into orbit? - Levits - 2018-02-13

Appreciate the help.

The thing is, it's not the lift. The plane travels in a straight line for the most part and depending on the angle of the turn can lose altitude (I've fiddled with the turn angle whereby I've made it to where it will lose altitude on a turn and have set it to balance out or gain altitude slightly on a turn); in the end, it doesn't seem to have any problems doing maneuvers.

But for some reason it refuses to stop climbing at the maximum altitude setting. It slowly makes it way up there over time which should have no problem being countered by the AI telling the thing to nose down...

Or, does the lift need to be set behind the center of mass?... or in front for the center of mass for the AI to know what to do?

The design really isn't the problem as far as I can tell, I can control it perfectly fine with WASD controls, I would think it is the AI and/or something that I setup on the design that is making it non-compatible.

Not sure if it makes a difference, but I also have the spinner setup automatically as I could not figure out how to get the AI to control it. So it is constantly running at full blast. <Potentially another thing that I can think of that would mess with the AI knowing what's going on.... suppose I could get an image up as well...

another thing that's crossed my mind just now, is there a certain AI setting that I should be using? I've used combat <of course it flew in a straight line (all the while gaining altitude and never stopping and it constantly climbs during combat), but I've also set the AI to patrol and the other, <this is where I'm seeing a problem as the AI should be keeping itself at a certain altitude.

[Image: 65822A4C3A2BBD72B18010E3D8165C13D63A4499]
The center of mass is in front and below where the lift indicator is and center a few blocks below where the cockpit glass meets the back. There are a few wing blocks on the back tail that should/would provide lift to force the nose down actually instead of up.
[Image: 49B91EE964C8781DD0FE531D0BCA259B15CF94E8]
Ripped the wings off the front... thing was still climbing?...

You know, it might be easier to upload the blueprint itself. If you can help with telling me how to do that as well I'd appreciate it too lol


RE: How to keep planes from going into orbit? - Liondrome - 2018-02-13

Click NEW REPLY instead of using the Quick Reply option, and at the bottom there is an attachment section, your blueprints will be under Documents/FromTheDepths/Player Profiles/"YourUserName"/Constructables

Another thing to try is lining up your CoM with your propellor. If your thrust source is under your CoM by too much it could be forcing your plane to nose up.


RE: How to keep planes from going into orbit? - Levits - 2018-02-13

Thanks again. Ok, found the blueprint... now I just need to figure out how to... send it? or post it.[/code]

...yeah sorry. I have no idea what I'm doing here.


RE: How to keep planes from going into orbit? - Levits - 2018-02-13

found it XD thanks had to reread what you said


RE: How to keep planes from going into orbit? - Liondrome - 2018-02-13

You still had too many wing pieces at the tail.


RE: How to keep planes from going into orbit? - Levits - 2018-02-13

really? that was it?... So, that is enough to throw off the whole thing? I guess I'll have to keep that in mind then. So the back tailfins (with I did use as basic wing blocks) provided enough lift to lift the whole thing and provide too much lift to the overall aircraft. That's just some weird physics XD.

Ok, I'll fix it up. Thanks again.

Something they should throw into their examples or a list of things to keep in mind:

"Too many wing blocks used on the tail will be enough to lift the whole thing."


RE: How to keep planes from going into orbit? - Liondrome - 2018-02-13

Yeah, a while back someone decided it would be a good idea to increase the amount of lift the pieces provide by 8x, and aircraft floating off to space is the result.


RE: How to keep planes from going into orbit? - MortusEclipse - 2018-02-13

With the lift so high you could make the body out of metal and it would still fly, though I am not sure if the speed would be effected.